hp cisco

HP and Cisco Link Aggregation Guide

This guide will go through the process of setting up link Aggregation on Cisco Switches, HP A Series Switches and HP E Series Switches. Over the 3 series of switches, Link aggregation is known as Trunking, Bridge Aggregation and Port Channel Configuration. All 3 mean the same thing, use a group of ports to provide load balancing, link resilience and maximize bandwidth. We will go through configuring each series of switch, then setup to use the LACP protocol and the finally allow VLANs over the links

Static Link Aggregation Configuration

Here over the 3 different series of switches we set up a standard link aggregation using two ports.

HP E Series

Here we setup port 1 and 2 and call it trk1

trunk 1-2 trk1 trunk

To see all your E series switch trunk information use the following command.

show trunk

For more info on E Series Trunking http://www.techieshelp.com/configuring-trunk-ports-on-the-hp-procurve/

Cisco Switches

Here again, we create a link aggregation group (1) and add port 1 and 2 to it .

interface port-channel 1
interface gigabitethernet 1/1
channel-group 1 mode on
interface gigabitethernet 1/2
channel-group 1 mode on

To check the configuration of trunks on a Cisco switch we use the following command.Where x is the group you want to check.

show interface port-channel x etherchannel

HP A Series

On the A Series switch its called Bridge Aggregation, here we set port 1 and 2 to be in group 1.

interface bridge-aggregation 1
interface gigabitethernet 1/0/1
port link-aggregation group 1
interface gigabitethernet 1/0/2
port link-aggregation group 1

To show our link aggregation information on the a series we use the below.

 display link-aggregation verbose

LACP Link Aggregation

I thought about trying to explain LACP however Wikipedia puts it much better into any words I could use, take a read then we will configure link aggregation to use LACP. http://en.wikipedia.org/wiki/Link_Aggregation_Control_Protocol#Link_Aggregation_Control_Protocol

HP E Series

Here we setup port 1 and 2 and call it trk1 and use LACP

trunk 1-2 trk1 trunk lacp

Cisco Switches

Here again, we create a link aggregation group (1) and add port 1 and 2 to it but this time we use the mode active command.

interface port-channel 1
interface gigabitethernet 1/1
channel-group 1 mode active
interface gigabitethernet 1/2
channel-group 1 mode active

 

HP A Series

On the A Series switch its called Bridge Aggregation, here we set port 1 and 2 to be in group 1.

interface bridge-aggregation 1
link-aggregation mode dynamic
interface gigabitethernet 1/0/1
port link-aggregation group 1
interface gigabitethernet 1/0/2
port link-aggregation group 1

Allowing VLANs Over Aggregated Links

Now we have created our aggregated links on our switches we need to set what vlan traffic is allowed over them, normally on links we allow all vlans, on the e series you have to specify the particular vlans.

E Series

Here we tag vlan 5 and 6 to the TRK1 trunk we created.

vlan 5 tagged trk1
vlan 6 tagged trk1

Cisco

Here we use port channel 1 we created, use the dot1q protocol and allow vlan 5 and 6 over it.

interface port-channel 1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 5-6

A Series

Here on the a series, we allow all of our vlans across BR1.

interface bridge-aggregation 1
port link-type-trunk
port trunk permit vlan all

You should now be able to setup link aggregation between HP and Cisco switches.

 

Tags: link aggregation

Allen White

Allen is a Consultant for ITPS in the North East of England and holds the following accreditations. MCSA, MCSE, MCTS, MCITP, CCA, CCSP, VCP 4,5 and HP ASE, AIS - Network Infrastructure.

Comments (3)

  • Avatar

    Larry

    |

    Hi Allen,

    Would your instructions for link aggregation work for HP switches only? Meaning, I’m not going between Cisco and HP switches. I have two Cat6 going to an AP that can aggregate and coming back to an HP switch (5406zl’s and 2910al’s). How would I do this?

    Thanks!

    Reply

    • Avatar

      Allen White

      |

      Hi Larry, if im reading correctly then yes you can, it would just be a case of running the following changing the ports to match yours (where 1 and 2 are the ports, trk1 is the name of the trunk)

      5406zl

      trunk 1-2 trk1 trunk

      2910al

      trunk 1-2 trk1 trunk

      if you have lldp enable show could then run a show lldp neighbour on the switches to see what they can see over the trk1.

      Reply

  • Avatar

    James Bond

    |

    Allen …….. you save my day. I was doing a maintenance all myself & had high chances of crossing downtime. Was having a hard time in getting port-channel functional between Cisco & HP but your article was a BIG help … Thanks A LOT !!!

    Reply

Leave a comment

Categories

Vote!

What Web Browser Do You Use?

View Results

Loading ... Loading ...

Vote!

What do you prefer..VMware or Hyper-V?

View Results

Loading ... Loading ...